due chiacchiere

I requisiti minimi di WordPress 3.2

L’altro giorno chiacchieravo in email con Davide a proposito delle novità introdotte dalla prossima versione di WordPress, di cui già i più curiosi possono scaricare la prima beta in anteprima. L’uso in “produzione” è ancora sconsigliato, visto che manca più di un mese al rilascio ufficiale, così l’ho installata sul mio server dove faccio le prove. La novità più evidente è la veste grafica parzialmente ridisegnata: non una rivoluzione come avvenne per la 2.7, ma comunque una semplificazione evidente delle varie funzionalità. In realtà, però, la vera notizia è l’innalzamento dei requisiti minimi per far funzionare WordPress sul proprio sito: PHP 5.2.4 e MySql 5.0. Non tutti i provider, ad oggi, supportano queste caratteristiche, quindi ti consiglio di far attenzione prima di effettuare l’aggiornamento.

Commenti

  1. Davide ha scritto:

    Diciamolo pure: è partito il countdown per Tophost… ๐Ÿ˜

    Risposte al commento di Davide

    1. camu ha scritto:

      @Davide: secondo me si aggiornano in tempo ๐Ÿ™‚

      Risposte al commento di camu

      1. Davide ha scritto:

        @camu: sarà meglio per loro… ๐Ÿ˜›

        Risposte al commento di Davide
        1. camu ha scritto:

          Certo non è solo un problema di Tophost… Chissà quanti provider in giro per il mondo saranno nei casini! Ma Aruba come sta messo? Ho letto che il passaggio alla 5 va fatto a mano impostando dei parametri nel loro pannello di controllo… Sai che confusione ci sarà? ๐Ÿ™‚

          Risposte al commento di camu
        2. Davide ha scritto:

          Non saprei, ma si direbbe che il passaggio sia avvenuto anni addietro…
          Tra l’altro anche hosting gratuiti come Altervista hanno PHP > 5.2.4 da tempo.

          Risposte al commento di Davide
        3. camu ha scritto:

          I commenti al post che segnali la fanno capire lunga sullo stato di soddisfazione degli utenti Aruba ๐Ÿ™‚ Riguardo a PHP 5, si ce l’hanno, ma su alcuni spazi non è attivo per default…

        4. camu ha scritto:

          @Davide: come vedi avevo ragione ๐Ÿ™‚

          Risposte al commento di camu
        5. Davide ha scritto:

          @camu: vedo, vedo! ๐Ÿ˜€

  2. Arquen ha scritto:

    Si parla di Tophost? Allora arrivo pur’io! ๐Ÿ˜›

    Sui “vecchi” nodi (ad esempio il 2):
    PHP 5.2.0
    MySql 5.0

    Sull’ultimo nodo (il 9):
    PHP 5.3.2
    MySql 5.1

    Risposte al commento di Arquen

    1. camu ha scritto:

      @Arquen: voglio credere che prima o poi li sincronizzeranno tutti ๐Ÿ™‚ Comunque da quello che leggo in giro la gente già da tempo sta chiedendo a Tophost di aggiornarsi, dato che altri sistemi come Joobleah e Drupalle richiedono quella versione di PHP mi pare…

      Risposte al commento di camu

      1. Arquen ha scritto:

        @camu: sì, alcuni lo stanno chiedendo da quasi un anno, ormai.

        Loro hanno risposto che i nuovi nodi hanno già le ultime versioni (perchè sono state installate direttamente quelle), mentre i vecchi non li aggiornano direttamente loro, ma aspettano che il S.O. che utilizzano (Debian) rilasci l’aggiornamento. Se ho capito bene…

        Risposte al commento di Arquen
        1. Arquen ha scritto:

          Ieri mi sa che ho sbagliato ad inserire qualche dato, sembravo un quasi anonimo. ๐Ÿ˜€

        2. camu ha scritto:

          @Arquen: si, esatto. Ma possibile che Debian non rilascia un aggiornamento in merito?

  3. Arquen ha scritto:

    Quella risposta l’hanno data parecchi mesi fa. E avevano aggiunto che nel giro di pochi mesi avrebbero fatto questo aggiornamento. Boh, non ti so dire.

    Risposte al commento di Arquen

    1. Davide ha scritto:

      @Arquen: al mio ultimo ticket, di quattro giorni fa, hanno risposto che «l’aggiornamento di php è previsto a breve». Ripeto: sarà meglio per loro, altrimenti sarà la loro fine definitiva.

      Risposte al commento di Davide

      1. camu ha scritto:

        @Davide: beh secondo me hanno visto il tuo gravatar col coltellaccio e si son messi paura ๐Ÿ™‚

        Risposte al commento di camu
        1. Arquen ha scritto:

          @camu: da domani tutti col coltellaccio. ๐Ÿ˜€

      2. Arquen ha scritto:

        @Davide: dipende da quante persone usano WordPress. Ovviamente non sarebbe una gran figura per loro se aggiornando WordPress mi ritrovassi con una pagina piena di errori.

        Mi spiegate una cosa (non sono un programmatore): quando si realizza uno script e questo può “girare” solo sull’ultima versione di PHP, qual è il motivo di questa scelta? Cioè, cosa viene infilato nel codice che porta a questo “limite”? ๐Ÿ˜ฎ

        Risposte al commento di Arquen
        1. camu ha scritto:

          @Arquen: i linguaggi di programmazione, come quelli naturali, si evolvono e si adattano alle esigenze di chi li usa. Come in Italiano non si usano più parole in voga nell’800 o a inizio 900, così in PHP alcuni comandi vengono “deprecati” ed altri nuovi, più potenti, vengono aggiunti. I nuovi comandi, in particolare, non esistendo nelle versioni precedenti di PHP, causerebbero un errore, perché il sistema non li capirebbe ๐Ÿ™‚ Non so nello specifico di WordPress quali nuovi comandi siano stati usati…

          Risposte al commento di camu
        2. Arquen ha scritto:

          @camu: ah, ho capito! Però, com’è, escono nuovi comandi ogni anno?

Lascia un commento

Torna in cima alla pagina