due chiacchiere

Vedi qualche avviso strano?

Oggi avrei bisogno di 2 minuti del tuo tempo. Come sai ho realizzato un plugin per le statistiche d’accesso del proprio blog, e volendo valutarne robustezza e leggerezza, lo sto sperimentando su me stesso (o meglio su questo blog), come farebbe ogni scienziato pazzo con la propria creatura. Mi dicono dalla regia che, aprendo le pagine con Internet Explorer (qualsiasi recente versione), appare un avviso di sicurezza, che avverte il navigante del fatto che io gli stia cercando di installare qualcosa sul computer. Cosa che sul mio computer non succede(va). Il motivo per cui ciò accade mi è noto: il mio plugin, tra le altre cose, raccoglie informazioni sulle estensioni attive sul tuo browser (Flash, Acrobat Reader, Silverlight, e via dicendo) e pare che la procedura per far questo, in Internet Explorer, faccia scattare quel fastidioso avviso. Da un paio di giorni ho modificato il codice, per cercare di evitare l’inconveniente. Ed ecco dove puoi essermi utile: potresti aprire questa pagina con Explorer, svuotare la cache (in genere basta fare il refresh) e dirmi se vedi strani avvisi sotto la barra degli indirizzi? Grazie.

Commenti

  1. soloparolesparse ha detto:

    IE8 direi tutto regolare…

  2. camu ha detto:

    @soloparolesparse: denghiu! (si vede che sono ancora raffreddato?)

  3. Sanghino ha detto:

    IE7 … appena provato e mi pare tutto OK !!!!

  4. larvotto ha detto:

    Solo un attimo, giusto il tempo di buttare il mio Mac e correre da MediaWorld a comprare un pc. Poi ti dico 😛

  5. alessio ha detto:

    tutto ok nella versione 6….6? Non lo so proprio mai sto coso….

  6. alessio ha detto:

    Correzzione!!! appena inviato il commento è venuto fuori il messaggio di cui parlavi, dice che le impostazioni di protezione stanno impedendo di utilizzare i controlli Activex, lo fa anche ad ogni refresh. Però strano, facendo il copia/incolla dell’indirizzo da Chrome, quando ho aperto IE la prima volta non mi è venuto nessun messaggio, dopo l’invio del commento precedente però…trac, lo fa ogni volta che apro la pagina.

    Se ti interessa dopo aver clieccato sulla spunta “non visualizzare più questo meassggio” il messaggio…non viene visualizzato più! (geniale no?)

  7. camu ha detto:

    @larvotto: beh, tu mi puoi aiutare con tutti i browser sul mac 🙂 Che so, Safari o Chrome…
    @tutti: ho dimenticato di specificare una cosa importante (grazie Alessio per avermelo fatto notare) e cioè che dovreste fare il refresh della pagina. Questo ricaricherà i javascript, che sono cambiati sicuramente ma voi in cache avete ancora quelli vecchi (vedi altro mio articolo di stamattina) e non notate nulla 🙂

  8. Piero_TM_R ha detto:

    Allora, con Opera ovviamente nessun segnale di allerta, fila tutto giusto.
    Ho appena provato ad aprire il tuo sito (ma anche il mio, visto che sto provando il tuo plug-in) e con la versione 8 di IE non viene fuori nessun messaggio.
    Sul mio viene fuori il triangolino giallo sulla barra in basso ed aprendola viene fuori questo -> http://yfrog.com/12erroreie8j Non so se sia legato all’errore che segnali tu.
    Con Mozilla nessun messaggio.

  9. Emanuele ha detto:

    Su OSX, né con Firefox, né con Safari appare nulla.
    Ciao,
    Emanuele

  10. camu ha detto:

    @Piero_TM_R: grazie! In merito all’errore sul tuo sito, mi capita anche con Firefox, e spulciando con la Web Developer Toolbar scopro che è legato al plugin Error: flickr-highslide che usi, in particolare al file highslide/highslide-with-gallery.packed.js
    Line: 28
    , magari vedi se gli sviluppatori hanno una soluzione in proposito 🙂
    @Emanuele: denghiu! O forse devo iniziare a parlarti in milanese adesso? 😀

  11. Caigo ha detto:

    Firefox e chrome ok.
    Il mio explorer non fa testo visto che non lo uso mai.

  12. Francesco ha detto:

    Ciao Camu,

    con Internet Explorer 8 tutto ok.

    Francesco

  13. camu ha detto:

    Grazie anche a voi 🙂 Francesco, hai provato a svuotare la cache del browser?

  14. Emanuele ha detto:

    Nono… che milanese… 😀
    Ciao,
    Emanuele

  15. Francesco ha detto:

    @camu: ho fatto il refresh. Pensi che sia sufficiente? In alternativa posso eliminare i file temporanei, ma non so se sia utile.

    Francesco

  16. camu ha detto:

    @Francesco: si si più che sufficiente, grazie 🙂

  17. Redemption ha detto:

    Nessun avviso strano con ff 3.6 . Ma penso sia in ritardo 😀

  18. camu ha detto:

    @Redemption: beh, la richiesta era per Internet Explorer, ma grazie lo stesso 🙂

  19. Silvana ha detto:

    Non so se ti serve ancora, ma non ho visto nessun avviso strano (vabbè che sono cecata ma penso tu possa fidarti).
    Sono entrata i internet explorer dopo un bel po’ di tempo, notare che l’ho fatto solo per te…

  20. camu ha detto:

    @Silvana: si certo che ancora mi interessa 🙂 Sono onorato dello sforzo che hai fatto solo per me, grazie!!!

Lascia un commento